Event ID - 3039

Event Id3039
SourceMSExchangeIMC
DescriptionThe error 0x80040115 was encountered while trying to communicate with the message store. An attempt to refresh the connection will be made. If not successful, the service will be shut down. Data (Words) 0000: 00140667 80040115
Event InformationAccording to Microsoft:
CAUSE 1:

This issue can occur on the Exchange Server computer that is running the Internet Mail Service if the header of a message contains malformed information:
--=_ Boundary 1-KTwEv4jY84Hk
Content-Type: text/plain;
charset = ""
Content-Transfer-Encoding: 7bit
RESOLUTION :
To resolve this issue:
1. Use the error messages that are generated to identify the message IDs of the malformed messages.
2. In Windows Explorer, locate the Imcdata\In and Imcdata\Out folders and either move or delete the messages that you identified as malformed. Search for messages that come from the same domain name. (In one situation where this issue occurred, all of the malformed messages came from one domain.)
3. Either apply the information store post-Exchange Server 5.5 Service Pack 3 (SP3) fix or upgrade the information store to version 2653.22 or later. The best way to upgrade the information store is to apply Exchange Server 5.5 Service Pack 4 (SP4).
4. Restart the Internet Mail Service and see if the information store keeps running and if messages are processed successfully.
5. If the Internet Mail Service brings in more malformed messages that may cause the information store to hang again, change the Internet Mail Service to outbound only:
a. Open the Internet Mail Service properties, and then click the Connections tab.
b. Under Transfer Mode, click Outbound only.
c. Click OK, and then and stop and restart the Internet Mail Service.
6. Restart the Internet Mail Service. If the information store keeps running and processes all messages, reconfigure the Internet Mail Service to both inbound and outbound.
7. Identify the malformed messages again (see step 1) and move the malformed messages (see step 2). You can do this on the Connections tab.
8. Restart the Internet Mail Service.
CAUSE 2:
The number of threads available to the IMC or IMS from the Information Store (IS
Reference LinksMalformed SMTP Messages in the Internet Mail Service

IMC Shuts Down, Error Connecting to IS

Store Crashes When POP3 Client Tries to Retrieve an NDR for a UTF-7 Message

Internet Mail Service Does Not Start Successfully

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