Event ID - 1166

Event Id1166
SourceMSExchangeDS
DescriptionError -1811 has occurred. JET_errFileNotFound. Internal ID 203017d. Contact Microsoft Technical Support for assistance.
Event InformationAccording to Microsoft:
CAUSE 1:
This problem may occur if you renamed the Exchange 5.5 service account to something other than the default value of "Administrator." This causes Setup to send incorrect parameters to the Exchange 2000 portion of the integrated setup, which results in the inability to successfully upgrade the Exchange 2000 Server component.
RESOLUTION :
To resolve this problem and successfully upgrade your Exchange Server 5.5 installation
1. Make a backup copy of the \Exchsrvr\Mdbdata folder.
2. Rename your administrator account back to:Administrator
3. Manually uninstall Exchange Server 5.5.For additional information
4. Verify that no settings are left behind from the unsuccessful Exchange 2000 Server upgrade
5. Reinstall Exchange Server 5.5 from CD 3 of the SBS 4.5 media. Be sure to use the same Organization and Site names as your original installation. When you are prompted for the service account, click the Administrator account that you renamed in step 2.
6. Reapply your Exchange 5.5 service pack to make the new Exchange installation the same service pack level as your earlier installation.
7. If you have an online backup of your Exchange 5.5 installation, restore from the tape at this point.
8. After you have restored the Exchange 5.5 data, rename the mailbox for the administrator account back to Administrator.
9. Click Start, point to Settings, click Control Panel, and then double-click Add/Remove Programs.
10. Click Microsoft Small Business Server 2000, and then click Change/Remove.
11. Follow the prompts in the SBS 2000 Setup Wizard until you come to the Component Selection screen. Verify that the action for Microsoft Exchange 2000 Server is set to Upgrade, and then complete the wizard.

When you cannot restart the directory service on Microsoft Exchange Server 5.0 after it stops for no apparent reason, you may receive an error message citing internal error -1811, with
Reference LinksSBS 2000 Exchange Setup Does Not Succeed with a Renamed Administrator Account

Directory Service Stops with Event IDs 1166 and 1002 and Internal Error -1811

XADM: Err Msg: Error 8 Has Occurred (Internal ID 30f0090)

Directory service does not start, event log shows error -510

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