Event ID - 1001

Event Id1001
SourceMicrosoft-Windows-LanguagePackSetup
DescriptionApplication initialization failed. Last error: %1
Event Information According to Microsoft :

Cause :

This event is logged when application initialization failed.

Resolution :

Set Windows Modules Installer and run Lpksetup again

There are various possible reasons why you received this error. The most common causes are:
  • Component-Based Servicing (CBS) failed to initialize.
  • Trusted Installer is busy or not functioning correctly.
  • The system state is invalid (for example, not enough memory or a corrupted registry).
You may be able to fix this this problem by ensuring that Modules Installer service is set to start automatically. If you continue to get this error, contact Microsoft Customer Service and Support (CSS). For information about how to contact CSS, see "Support Options from Microsoft Services".

To set Modules Installer service to start automatically:
  1. Click the Start button, type services in the Start Search box, and click on it in the Programs list.
  2. Find Windows Modules Installer in the list.
  3. If the startup type is not Automatic , then right-click Windows Modules Installer , and select Automatic in the Startup Type drop-down list.
  4. Restart the computer and run Lpksetup again.
Verify :

To verify that the language pack was successfully installed or removed:
  1. In Control Panel, click Change display language (located under the Clock, Language, and Region section).
  2. Verify the language is listed (or not listed) in the drop-down list.
Note : The drop-down list will only be visible if you have already installed a language pack or if your operating system supports Multilingual User Interface (MUI). MUI language packs can only be installed on Windows Vista Ultimate and Windows Vista Enterprise.
Reference LinksEvent ID 1001 from Microsoft-Windows-LanguagePackSetup

Catch threats immediately

We work side-by-side with you to rapidly detect cyberthreats
and thwart attacks before they cause damage.

See what we caught

Did this information help you to resolve the problem?

Yes: My problem was resolved.
No: The information was not helpful / Partially helpful.