Event ID - 10016

Event Id10016
SourceDCOM
DescriptionThe %1 permission settings do not grant %2 %3 permission for the COM Server application with CLSID %4 to the user %5\%6 SID (%7). This security permission can be modified using the Component Services administrative tool.
%1 = machine-default, application-specific; %2 = local, remote; %3 = launch, activation; %4 = ; %5 = /; %6 = .

or

The application-specific permission settings do not grant Local Launch permission for the COM Server application with CLSID {AppGUID} to the user User_Name SID User_SID. This security permission can be modified using the Component Services administrative tool.
Event InformationAccording to Microsoft :
Cause :A program, the Clsid displayed in the message, tried to start the DCOM server by using the DCOM infrastructure. Based on the security ID (SID), this user does not have the necessary permissions to start the DCOM server.
Resolution :
Verify that the user has the appropriate permissions to start the DCOM server.
To assign permissions
1.Using Regedit, navigate to the following registry value
HKCR\Clsid\clsid value\localserver32
The clsid value is the information displayed in the message.
2.In the right pane, double-clickDefault. TheEdit String dialog box is displayed. Leave this dialog box open.
3.ClickStart, and then clickControl Panel.
4.Double-clickAdministrative Tools, and then double-clickComponent Services.
5.In the Component Services snap-in, expandComputers, expandMy Computer, and double-clickDCOM Config.
6.In the right pane, locate the program by using its friendly name.
7.Right-click the program name, and then selectProperties.8.On theSecurity tab, in theLaunch and Activation Permissions group box, select Customize, and then clickEdit.
add the user to the permissions list, and give the user the appropriate permissions.
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According to News Group :
Cause 1:
The Launch and Activation Permissions are not set correctly on the FrameworkService DCOM component.
Resolution 1 :
Change theLaunch and Activation Permissions for the FrameworkService DCOM component fromCustomize toUse Default.
1.Open theComponent Services MMC snap-in (Start, Control Panel, Administrative Tools, Component Services.
2.InComponent Services navigate to Console Root - Computers - My Computer - DCOM Config.
3.Right-clickFrameworkService and selectProperties.
4.Select the Security tab.
5.UnderLaunch and Activation Permissions selectUse Default.
6. Click OK
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Resolution 2:
To correct this error do the following:
1. Open Component Services, go to Computers -> My Computers -> DCOM Config.
2. Expand DCOM config until you get down to the CLSID, they appear after the named items.
3. Right click the CLSID, check the launch parameters; they will probably be set to custom and not containing any accounts.
4. Use the SID in the event log item, run it against PsGetSid, to get which account is needed.
5. Put that account in and configure the necessary requested launch permissions.
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Cause :
This issue occurs if the domain user account that you specified as the Windows SharePoint Services 3.0 service account does not have the Local Activation permission to the IIS Wamreg Admin Service.
Resolution :
If you want to prevent the event ID error messages from being logged in the System log, use the Component Services snap-in to enable the Local Activation permission to the IIS Wamreg Admin Service for the domain user account that you specified as the Windows SharePoint Services 3.0 service account. To do this, follow these steps:
1.ClickStart, clickRun, typedcomcnfg in theOpen box, and then clickOK.
2.Expand Component Services, expandComputers, expandMy Computer, and then click DCOM Config.
3.Right-clickIIS WAMREG admin Service, and then clickProperties.
4.Click theSecurity tab.
5.UnderLaunch and Activation Permissions, clickEdit.
6.In theLaunch Permission dialog box, clickAdd.7.In theSelect Users, Computers, or Groups dialog box, type the domain user account that you specified as the Windows SharePoint Services 3.0 service account, clickCheck Names, and then clickOK.
8.In thePermissions for UserName list, click to select theAllow check box that is next toLocal Activation, and then clickOK two times.
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Cause :
This issue may occur if the netman component in DCOM does not have the following permissions:<.br>1.Remote Launch
2.Local Activation
3.Remote Activation
Resolution :
To resolve this issue , follow these steps:
1.ClickStart, clickRun, typedcomcnfg, and then clickOK.
2.In Component Services, double-clickComponent Services, and then double-clickComputers.
3.ExpandMy Computer, expand DCOM Config, and then clicknetman in theDCOM Config node.
4.Right-clicknetman, and then click Properties.
5.In thenetman Properties dialog box, click theSecurity tab.
6.UnderLaunch and Activation Permissions, clickEdit.
7.In theLaunch Permission dialog box, clickAdd.
8.In theEnter the object names to select box, typeNetwork Service, and then clickOK.
9.WhileNetwork Service is selected, click to select the Allow check boxes for the following items:
1)Remote Launch
2)Local Activation
3) Remote Activation
10. Click OK two times.
Reference LinksEvent ID 10016 from Source DCOM

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